В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
danilkuzin201
danilkuzin201
22.10.2022 16:14 •  Информатика

В dev c++ Дан массив размера N. Вывести массив на экран в строчку. Найти номер его первого локального максимума.
Локальный максимум – это элемент, который больше любого из своих соседей.
Входные данные размерность массива: 5 0 5 89 10 100
Выходные данные 0 5 89 10 100
Номер элемента массива, первого локального минимума - 3

Ответ:
Belka1985
Belka1985
15.10.2020 13:53

#include <iostream>

int main() {

using namespace std;

setlocale(LC_ALL, "Russian");

int N;

cout << "Введите размерность массива: ";

cin >> N;

int* A = new int[N];

for (int i = 0; i < N; i++)

{

 cout << "Заполните [" << i + 1 << "] элемент: ";

 cin >> A[i];

}

cout << endl;

for (int i = 0; i < N; i++)

{

 cout << A[i] << " ";

}

int max_index = 0;

for (int i = 1; i < N; i++)

{

 if (A[i] > A[max_index]) {

  max_index = i;

 }

}

cout << "\nНомер локального максимума: " << max_index + 1;

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?