В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Марина1212х
Марина1212х
05.04.2022 14:18 •  Информатика

Ниже на трех языках программирования записан алгоритм. Получив на вход натуральное десятичное
число x, этот алгоритм печатает два числа: L и M. Укажите наибольшее число x, при вводе которого алгоритм
печатает сначала 35, а потом 3.

var x, L, M: longint;
begin
readln(x);
L := 1;
M := 0;
while x > 0 do begin
M := M + 1;
if x mod 3 <> 0 then
L := L * (x mod 9);
x := x div 9
end;
writeln(L);
writeln(M)
end.

Ответ:
Kachelda
Kachelda
24.12.2023 21:17
Для решения этой задачи, давайте разберемся, что делает данный алгоритм шаг за шагом.

1. Первоначально объявляем переменные x, L и M типа longint.
2. С помощью команды readln(x) мы считываем значение переменной x с клавиатуры.
3. Устанавливаем значение L равным 1 и значение M равным 0.
4. Запускаем цикл while, который будет выполняться до тех пор, пока значение переменной x больше 0.
5. В каждой итерации цикла увеличиваем значение переменной M на 1.
6. С помощью оператора if проверяем, что значение x, деленное на 3, не равно 0 (x mod 3 <> 0).
- Если это условие выполняется, то выполняем следующую команду: L := L * (x mod 9).
Здесь x mod 9 - это остаток от деления x на 9.
То есть, мы умножаем текущее значение L на остаток от деления x на 9.
- Если условие не выполняется, пропускаем эту команду и переходим к следующей строке.
7. В каждой итерации цикла делим значение переменной x на 9, используя оператор x := x div 9.
Это позволяет нам последовательно изменять значение x на его целую часть от деления на 9.
Например, если x = 27, то после первой итерации цикла значение x станет равным 3.
8. По достижении условия x > 0, цикл завершается.
9. Дальше мы выводим значения L и M с помощью команд writeln(L) и writeln(M).

Теперь, чтобы найти наибольшее число x, при вводе которого алгоритм печатает сначала 35, а потом 3, нужно последовательно проверять числа от большего к меньшему.

- Для начала, найдем такое значение x, при котором алгоритм выведет 3 на первой строке.
Найдем наименьшее натуральное число, не равное 0, которое при делении на 9 даёт остаток 3.
Это число будет равно 3, потому что 3 mod 9 = 3.
- Теперь проверим, какие значения выведутся на первой строке алгоритма при вводе 3.
Для этого заменим x на 3 и симулируем выполнение алгоритма шаг за шагом:
1. Устанавливаем L = 1 и M = 0.
2. Запускаем цикл while.
3. Увеличиваем M на 1, M = 1.
4. Проверяем x mod 3 <> 0, так как 3 mod 3 = 0, то условие не выполняется.
5. Переходим к следующей итерации цикла.
6. Делим x на 9, x = 3 div 9 = 0.
7. Условие x > 0 не выполняется, цикл завершается.
8. Выводим значения на первой и второй строках - L = 1, M = 1.

Итак, мы видим, что при вводе значения 3 алгоритм вывел сначала 1, а затем 1.

- Теперь найдем наибольшее число x, при вводе которого алгоритм выведет сначала 35, а потом 3.
Найденное нами ранее число 3 не удовлетворяет условию вывода 35 на первой строке.
Поэтому мы должны найти другое число, при котором L = 35 и M = 3.
Начнем проверять числа, начиная с числа 9999 (максимальное 4-х значное число, состоящее из 9).

Подставим каждое число последовательно в алгоритм и проверим результат.

- При подстановке числа 9999 получаем:
- L = 9 * 9 * 9 = 729
- M = 4
Очевидно, что это число не подходит, так как L = 729, а не 35.

- При подстановке числа 999 получаем:
- L = 9 * 9 * 9 = 729
- M = 3
Снова получаем L = 729, а не 35, поэтому это число также не подходит.

- Далее, проверяем число 99:
- L = 9
- M = 2
При выводе чисел получаем L = 9, M = 2. Это тоже не наше число.

- И, наконец, проверяем число 9:
- L = 9
- M = 1
При выводе чисел получаем L = 9 и M = 1. Это также не наше число.

Итак, мы проверили все возможные значения и не нашли число, при котором алгоритм печатает сначала 35, а потом 3.
Значит, такое число не существует.

Ответ: Не существует натурального числа x, для которого алгоритм печатает сначала 35, а затем 3.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?