В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
darinchiiik
darinchiiik
03.04.2022 09:49 •  Информатика

Составить программу на языке паскаль для вычисления суммы всех четных чисел на интервале от 1 до н. (9 )

Ответ:
лолчик6
лолчик6
09.06.2020 21:57

Объяснение:

var

i,n,s:integer;

begin

write('Введите n=');

readln(n);

s:=0;

while i<=n do

begin

if i mod 2=0 then s:=s+i;

i:=i+1;

end;

writeln('s=',s);

readln;

end.

И чуть короче с циклом for

var

i,n,s:integer;

begin

write('Введите n=');

readln(n);

s:=0;

for i:=1 to n do

if i mod 2=0 then s:=s+i;

writeln('s=',s);

readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?