В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
алик143
алик143
24.03.2021 07:48 •  Информатика

ПИТОН! ОТ Обратное число

В этой задаче нужно ответить на 1≤≤105

1

≤

t

≤

10

5

запросов. Каждый запрос состоит из двух целых чисел 2≤≤109

2

≤

p

≤

10

9

и 0<<

0

<

a

<

p

, число

p

является простым. На каждый запрос нужно вывести в отдельной строке целое число 0<<

0

<

b

<

p

такое, что (⋅−1) ⋮

(

a

⋅

b

−

1

)

⋮

p

.

Входные данные

В первой строке дано целое число

t

— количество запросов.

В следующих

t

строках даны по два числа

p

i

и

a

i

, =1,…,

i

=

1

,

…

,

t

.

Выходные данные

Выведите

t

целых чисел (каждое число в отдельной строке) — ответы на запросы.

Примеры

Ввод

Вывод

4

5 1

5 2

5 3

5 4

1

3

2

4

Ограничения

Время выполнения: 5 секунд

Ответ:
Shmanin32
Shmanin32
15.10.2020 13:20

b = []

for x in range(int(input())):

   a = list(map(int, input().split()))

   b.append(pow(a[1], a[0] - 2, a[0]))

print('\n'.join(map(str, b)))

Объяснение:

Эта программа зашла.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?