В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Pascal В списке участников международной конференции указывается их национальность и возраст. Список упорядочен по возрасту участников. Определить самого молодого и самого пожилого русского участника. Нужно написать программу.

Ответ:
trubadurov01
trubadurov01
15.10.2020 13:18

Держи ;)

Var year,s,y,o:integer; old,young,name,nation:string;

Begin

s:=0;

o:=0;

y:=200;

While (s=0) do

Begin

Write('Введите имя и фамилию участника. Если список окончен, напишите "конец": ');

Readln(name);

If (name='конец') then break;

Write('Введите национальность участника: ');

Readln(nation);

Write('Введите возраст участника: ');

Readln(year);

If (year > o) and (nation='русский') then

Begin

o:=year;

old:=name;

end;

If (year < y) and (nation='русский') then

Begin

y:=year;

young:=name;

end;

end;

Write('Самый молодой русский участник - ',young,', самый старый русский участник - ',old);

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?