В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
MrDeff
MrDeff
10.11.2021 02:56 •  Информатика

НУЖНО НАПИСАТЬ КОД НА ПИТОНЕ ИЛИ НА С Извините, что последние)

Сокращение дроби
Дана дробь ab. Требуется её сократить, то есть записать это же число в виде cd, где c — целое число, d — натуральное число и d минимальное возможное.

Входные данные

Вводятся два целых числа a и b (–100≤a≤100, 0
Выходные данные

Выведите два числа c и d.

Примеры
Ввод 1
18 27
Вывод
2 3

Ответ:
25marta52
25marta52
15.10.2020 12:56

Python

a, b=map(int,input().split())

c=a

d=b

for i in range(-101,101):

   if i!=0 and a%i==0 and b%i==0 :

       c=a//i

       d=b//i

print(c,d ,end=" ")

а эффективней использовать алгоритм Евклида.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?