В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
hamkarmik225
hamkarmik225
12.07.2020 03:33 •  Информатика

Написать программу для С#!
Написать программу решения следующей задачи: Определить, является ли «счастливым» трамвайный билет с шестизначным номером («счастливым» считается билет, у которого сумма первых трёх чисел совпадает с суммой трёх последних чисел). ответ вывести на печать.​

Ответ:
Molina1234
Molina1234
15.10.2020 12:42

вот возможный вариант, если числа номер вводится с клавиатуры:

#include <iostream>

#include <clocale>

using namespace std;

int main()

{

setlocale(LC_ALL, "Russian");

int a, b, c, d, e, f;

int x = 0;

cout << "Введите номер билета: ";

cin >> a >> b >> c >> d >> e >> f;

x = a + b + c;

if ( x == d + e + f)

 cout << "Номер вашего билета: " << a << b << c << d << e << f << ". " << "Ваш билет счастливый!";

else cout << "Номер вашего билета: " << a << b << c << d << e << f << ". " << "Увы, ваш билет не счастливый.";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?