В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
125894
125894
03.09.2020 23:58 •  Информатика

Дан целочисленный одномерный массив A(N). Инвертировать элементы этого массива.

Написать программу в консольном приложение Dephi на языке pascal для начинающих

Ответ:
romanowacristi
romanowacristi
15.10.2020 12:46

const N = 10;

var

   a: array[1..N] of integer;

   i: byte;

   b: integer;

begin

   for i:=1 to N do

       read(a[i]);

 

   for i:=1 to N div 2 do begin

       b := a[i];

       a[i] := a[N-i+1];

       a[N-i+1] := b;

   end;

 

   for i:=1 to N do

       write(a[i],' ');

 

   writeln;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?