В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zlatasidorowa
zlatasidorowa
14.02.2020 07:56 •  Информатика

Напишите программу в Питоне, которая в последовательности натуральных чисел определяет сумму чисел, кратных 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 6. Количество чисел не превышает 100. Введённые числа не превышают 300. Программа должна вывести одно число – сумму чисел, кратных 6.

Ответ:
Vika17112003
Vika17112003
15.10.2020 12:38

print(sum([i for i in [int(input()) for _ in range(int(input()))] if i % 6 == 0]))

0,0(0 оценок)
Ответ:
Руслана5999226
Руслана5999226
15.10.2020 12:38

--- Python 3.7.0 ---

def ReadSeq(SeqLen: int, CastType):

  for _ in range(SeqLen):

      yield CastType(input())

def main():

   RawSequence = ReadSeq(int(input()), int)

   Selector = lambda item: (item % 6 == 0)

   FilteredSequence = filter(Selector, RawSequence)

   print(f'Res: {sum( list( FilteredSequence ) )}')

if __name__ == "__main__":

   main()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?