В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kochanovaleksa
kochanovaleksa
10.05.2021 14:21 •  Информатика

Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шагом h.


x∈[0,π]
h=π/8

Используя var, const, writeln и т.д.


f= \frac{sinx+cosx}{1+x^2}
Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шаго

Ответ:
nysha046
nysha046
06.08.2020 20:24
begin var f: real -> real := x -> (sin(x)+cos(x))/(1+sqr(x)); PartitionPoints(0, Pi, 8).Tabulate(x -> f(x)) .ForEach(x->writeln('x:',x.Item1:7:3,'    y:',x.Item2:7:3)); end.

или без косметики:

begin PartitionPoints(0,Pi,8).Tabulate(x->(sin(x)+cos(x))/(1+sqr(x))).Print end.

Примеры работ:


Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шагом
Составить программу вычисления функции на паскале АВС.NET на заданных промежутках и с заданным шагом
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?