В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
yla00458
yla00458
25.02.2022 11:08 •  Информатика

Написать программу, которая считывает текст из файла и выводит на экран предложения, содержащие цифры.

Ответ:
HaCT9I3
HaCT9I3
28.05.2020 20:32

Программа:

program files;

var f: text;

   c: string;

begin

 

 assign(f, 'path/to/file.txt');

 reset(f);

 

 while not eof(f)

 do begin

      readln(f,c);

      if(c.Contains('1') or c.Contains('2')

           or c.Contains('3') or c.Contains('4')

             or c.Contains('5') or c.Contains('6')

               or c.Contains('7') or c.Contains('8')

                 or c.Contains('9'))

      then writeln(c);

 end;

 

 close(f);

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?