В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vitakotov009
vitakotov009
30.05.2021 02:07 •  Информатика

Составить программу нахождения произведения нечетных чисел от 1 до 100 (цикл с постусловием)
Составить программу нахождения суммы четных от 2 до 100

Ответ:
diamiss45
diamiss45
15.10.2020 09:32

Т.к. требуется использовать цикл until, то значит требуется код на языке Паскаль.

1) цикл for

program p_for

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  p := 1;//начальное значение

  for i := 1 to n do  

     p := p * i;

  writeln(p);

end.  

2) цикл while

program p_while

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  while i <= n do  

  begin

     p := p * i;

     i := i + 1;

 end;

 writeln(p);

end.  

3) цикл until

program p_until

var

  p:  real;

  i, n: integer;

begin

  readln(n);

  i := 1;

  p := 1;//начальное значение

  repeat

     p := p * i;

     i := i + 1;

  until i > n;

  writeln(p);

end.  

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?