В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
shefer84
shefer84
07.11.2020 11:16 •  Информатика

Написать программу нахождения суммы и произведения всех трехзначных чисел кратных 3!

Ответ:
ismaildior200920
ismaildior200920
09.06.2020 16:58

program raf105;

var i,sum,pro,a:integer;

begin

writeln('Вводите 5 чисел по очереди');

pro:= 1;

 for i:=1 to 5 do

 begin

  readln(a);

  if (a>=100) and (a<=999) and ((a mod 3)=0)

    then

    begin

    sum+= a;

    pro*= a;

    end;

  end;

writeln('Сумма трёхзначных  чисел кратных трём: ',sum);

writeln('Произведение трёхзначных  чисел кратных трём: ',pro);

end.

Язык PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?