В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
retul
retul
28.04.2022 17:05 •  Информатика

Pascal написать программу проверяющую есть ли в заданном слове две подряд идущие одинаковые буквы

Ответ:
Uspex11111
Uspex11111
30.09.2020 15:47

program raf105;

var  

s:string;

x:boolean;

i:integer;

begin

write('Введите слово: ');

readln(s);

s:= lowercase(s);

for i:=2 to length(s) do

 if not x

   then x:= s[i] = s[i-1];

if x

 then writeln('В слове есть две подряд идущие, одинаковые буквы')

 else writeln('В слове нет двух подряд идущих, одинаковых букв');

end.

Язык PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?