В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
anas20041006
anas20041006
12.08.2020 12:47 •  Информатика

Составить программу, в которой посчитать кол-во гласных в строке. (в pascal)(тема: двумерные массивы)

Ответ:
Medewjik
Medewjik
09.06.2020 11:37

program raf105;

var a:array[1..100,1..2] of char;

glas,s:string;

i,j,sumglas:integer;

begin

glas:='аеёиоуыэюя'; // Перечисление гласных

for i:=1 to length(glas) do

 a[i,2]:= glas[i]; //Заполнение второй строки для гласных

writeln('Введите строку');

readln(s);

for i:=1 to length(s) do

 a[i,1]:= s[i]; //Заполнение первой строки для введённых букв

for i:=1 to length(s) do

 for j:=1 to length(glas) do

   if a[i,1] = a[j,2] //если символ из строки 1 = символу из строки 2

     then sumglas:= sumglas+1; //Прибавление единицы к счётчику

writeln('В строке ',sumglas,' гласных');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?