В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
zhanik2017
zhanik2017
22.07.2021 04:20 •  Информатика

Напиши программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 6.
Количество чисел не превышает 500. Введённые числа не превышают 10000. Программа должна вывести одно число — минимальное число, оканчивающееся на 6.

Входные данные
5
26
16
36

Выходные данные
16​​

Ответ:
Potashka
Potashka
15.10.2020 02:05

var n, i, k, j, d:integer;

begin

d= 9996;

write('Введите кол-во чисел: ');

readln(n);

for i:= 1 to n do begin

write('Введите число: ');

readln(j);

if j mod 10 = 6 then

if j < d then d:= j;

end;

writeln(d);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?