В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
katasinicina39
katasinicina39
25.05.2021 21:05 •  Информатика

Напишите программу, которая выводит случайные числа от 10 до 20 и подсчитывает чётные числа

Ответ:
TheTanyaStar2k
TheTanyaStar2k
15.10.2020 00:56

var

 i,a,count,sum:integer;

begin

 count:=0; sum:=0;

 write('Кол-во чисел: '); readln(a);

 for i:=1 to a do

   begin

     a:=random(11)+10;

     write(a:4);

     if a mod 2 = 0 then

       begin

         inc(count);

         sum:=sum+a;

       end;

   end;

 writeln;

 write('Sum: ',sum,' Count: ',count);

end.1

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?