В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AnnYtAa1
AnnYtAa1
27.06.2020 22:10 •  Информатика

Написать программу, которая определяет числу,введенному с клавиатуры его абсолютную величину (модуль) не используя команду abs(x). (Например: вводят число "-9", программа выдает "9", или вводят "2" и выводится "2.").

Ответ:
mrfenics
mrfenics
15.10.2020 00:25

C++

#include <iostream>

using namespace std;

int main()

{

int number = 1;

cout << "Input number - ";

cin >> number;

cout << endl;

int abs = 0;

number < 0 ? abs = -number : abs = number;

cout << "Abs(" << abs << ")" << endl;

return 0;

}

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?