В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Казань565
Казань565
22.06.2021 19:21 •  Информатика

Написать программу паскаль.
Дано n натуральных чисел, которые вводятся по одному. Найти: произведение чисел.

Ответ:
Diana451111
Diana451111
18.05.2020 21:30

Код на PascalABC.NET:

var a: real;

begin

var a := ReadReal('Введите a: ');

var a2,a4,a8: real; // вс переменные

var a2 := a * a;

var a4 := a2 * a2;

var a8 := a4 * a4;

Println(a,$'{a} в степени 8 = {a8}');

end.

-

Program n1;

var n,k,i: integer;

begin

k:=0;

readln(n);

for i:=10 to 99 do if (i mod 10)*(i div 10)=n then k:=k+1;

write(k);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?