В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Whitecat111
Whitecat111
10.04.2021 16:55 •  Информатика

C++ Нарисовать блок-схему и написать программу для решения задач:
1. Дано число. Если оно меньше 7, то вывести Yes, если больше 10, то вывести No, иначе вывести Error.

2. Даны два числа. Если первое число больше второго, то вывести yes, иначе поменять значения этих переменных и вывести их на экран.

3. Даны два числа. Определить, являются ли числа одного знака или хотя бы одно из них равно нулю. (Подсказка: чтобы определить какого знака числа, нужно посмотреть на их произведение)

Ответ:
Kirikplay11
Kirikplay11
24.08.2020 18:18

1 задача:

#include <bits/stdc++.h>

using namespace std;

int main() {

   long long a;

   cin >> a;

   if (a < 7) cout << "Yes";

   else if (a > 10) cout << "No";

   else cout << "Error";

   return 0;

}

2 задача:

#include <bits/stdc++.h>

using namespace std;

int main() {

   long long a, b;

   cin >> a >> b;

   if (a > b) cout << "yes";

   else {

       long long c = a;

       a = b;

       b = c;

       cout << a << ' ' << b << endl;

   }

   return 0;

}

3 задача:

#include <bits/stdc++.h>

using namespace std;

int main() {

   long long a, b;

   cin >> a >> b;

   if (a * b >= 0) cout << "YES";

   else cout << "NO";

   return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?