В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Nikto58
Nikto58
05.02.2020 21:06 •  Информатика

Паскаль: определить сколько раз встречается число k при генерации чисел с цикла for (элементы сгенерировать randomom)

Ответ:
Ясте
Ясте
09.06.2020 02:26

program raf105;

var n,k,i,raz:integer;

begin

write('Сколько чисел нужно сгенерировать?: ');

readln(n);

write('Число, которое нужно посчитать (k): ');

readln(k);

for i:=1 to n do

if (random(0,100))=k

 then raz:= raz+1;

writeln('Из ',n,' сгенерированных чисел число ',k,' встретилось ',raz,' раз');

end.

Язык программирования PascalABC

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?