В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
jasmkal
jasmkal
19.12.2020 09:59 •  Информатика

решить на языке програмирования PASCAL ABC.
Напишите программу, которая запрашивает у пользователя числа и находит их сумму. Признаком окончания ввода является число 10.
Вход
5 6 2 10 8
Выход
13 (это сумма чисел 5, 6, 2. 10 – это конец цикла).
Заранее благодарю

Ответ:
alinamironova21
alinamironova21
14.10.2020 19:40

var

ch,sum:LongInt;

begin

ReadLn(ch);

sum:=0;

while (ch>10) or (ch<10) do

begin

inc(sum, ch);

ReadLn(ch);

end ;

WriteLn(sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?