В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
danilcoptsov1
danilcoptsov1
03.11.2020 04:08 •  Информатика

Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон.Если существует такой треугольник, то определите его тип (равносторонний, равнобедренный, разносторонний)

Пример

Не существует a b c>> 1 2 1

Равносторонний a b c>> 2 2 2

Равнобедренный a b c>> 20 20 30

Разносторонний a b c>> 3 4 5

Ответ:
ника2760
ника2760
06.09.2020 12:22

var a, b, c: integer;begin

    readln(a, b, c);

    if (a + b <= c) or (b + c <= a) or (a + c <= b) then

         writeln('Не существует')

    else if(a = b)and(b = c) then

         writeln('Равносторонний')

    else if(a = b)or(b = c)or(a = c) then

         writeln('Равнобедренный')

    else

        writeln('Разносторонний')

end.

Объяснение:

Всё строится на проверках длин сторон, за у пользователя

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?