В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Написать код программы , который в последовательности натуральных чисел определяет максимальное число. Программа получает на вход количество чисел в последовательности, а затем сами числа.

Ответ:
llll23
llll23
14.10.2020 13:33

program z1;

var a, i, n, max: integer;

begin

max:=0;

write ('Введите количество чисел в последовательности ');

readln (n);

for i:=1 to n do

begin

write ('Введите натуральное число ');

readln (a);

if a > max then max:=a

end;

writeln('Максимальное число в последовательности ',max)

end.

Объяснение:

Т.к. программа будет получать на вход натуральные числа, то первоначальным значением для переменной max можно взять 0.

Он не является натуральным числом, но все натуральные числа больше него.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?