В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
taskarin02
taskarin02
31.03.2021 10:16 •  Информатика

Написать программу вывода на экран всех трехзначных чисел, кратных и 6, и 4, и заканчивающихся на цифру 8. программу написать темя с использованием циклов for, while, repeat. !

Ответ:
margomds
margomds
08.06.2020 15:05

 Var i:integer;

begin

for i:=100 to 999 do if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' ');

end.

 

{While}

Var i:integer;

begin

 i:=100;

while i<=999 do begin

if( if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' '); inc(i); end;

end.

 

 

 {Repeat}

Var i:integer;

 begin

i:=100; 

repeat

begin

 if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' ');

inc(i); end; 

until i<1000;

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?