В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
eiljo
eiljo
16.08.2020 11:20 •  Информатика

Снежинка

Дано нечётное число n. Создайте двумерный массив из n×n элементов, заполнив его символами "." (каждый элемент массива является строкой из одного символа). Затем заполните символами "∗" среднюю строку массива, средний столбец массива, главную диагональ и побочную диагональ. Для этого не нужно использовать вложенные циклы.

В результате символы "звёздочка" в массиве должны образовывать изображение снежинки. Выведите полученный массив на экран, разделяя элементы массива пробелами.

Входные данные

В одной строчке задано число n≤21.

Выходные данные

ответ на задачу.

Примеры

Ввод
5
Вывод
* . * . *
. * * * .
* * * * *
. * * * .
* . * . *

код на языке python 3

Ответ:
Богатство87
Богатство87
14.10.2020 12:14

n = int(input())

a = [["."] * n for i in range(n)]

for i in range(n):

   # линия по диагонали

   a[i][i] = "*"

   # линия обратной диагонали

   a[n - 1 - i][i] = "*"

   # линия по вертикали

   a[i][n//2] = "*"

   # линия по горизонтали

   a[n//2][i] = "*"

print('\n'.join([' '.join([str(i) for i in row]) for row in a]))

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?