В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Ерко365
Ерко365
18.04.2021 01:04 •  Информатика

Написать программу на паскале, которая вычислит точки пересечения двух функций.

Ответ:
gogopuppies
gogopuppies
08.06.2020 13:27

ax^2 +bx+c=y
y=kx+q*

 

ax^2 + bx + c = kx + q
ax^2 + (b - k) x + (c - q) = 0

 

var
a, b, x, k, q, D : real;
begin
read (a, b, x, k, q);

D := sqr ((b - k)) - 4 * a * (c - q);
if D < 0 then writeln ('Нет перечечений')
else
begin
writeln (((k - b) + sqrt (D)) / (2 * a));
writeln (((k - b) - sqrt (D)) / (2 * a));
end;
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?