В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Lena12281995
Lena12281995
22.01.2020 23:48 •  Информатика

Напишите программу, которая удаляет из введенной строки любой введенный с клавиатуры символ

Ответ:
bobbobbobgy1
bobbobbobgy1
14.10.2020 10:46

Тут значительно легче без процедур решить. Вот, получайте!

program prim;

Var

s : string;

t : char;

k: integer;

begin

writeln ('Введите строку');

readln (s);

writeln ('Введите символ, который надо удалить');

readln (t);

while pos(t,s)<>0 do

begin

k:=pos(t,s);

Delete(s, k, 1);

end;

writeln ('Результат после удаления: ');

writeln(s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?