В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Krosarik
Krosarik
04.08.2020 01:50 •  Информатика

Напишите программу в паскале для решения квадратных уравнений ​

Ответ:
roncray1
roncray1
08.06.2020 11:28

procedure solution(k,y,z : real);

var

D,x1,x,x2:real;

begin

D:=y*y-4*k*z;

if D>0 then

 begin

   x1:=(-y+sqrt(D))/2*k;

   x2:=(-y-sqrt(D))/2*k;

   writeln('x1=',x1);

   writeln('x2=',x2);

 end

else if D=0 then

 begin

   x:=-1y/2*k;

   writeln('x=',x);

 end

else

 writeln('Нет вещественных корней');

end;  

var

a,b,c :real;

begin

writeln('Введите коэфиценты a,b,c');

read(a,b,c);

solution(a,b,c);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?