В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
AndaDi
AndaDi
18.11.2022 09:47 •  Информатика

Напишите программу, которая вычисляет произведение всех чисел, оканчивающихся на 2, из диапазона от 0 до 50.

Ответ:
nikakri14
nikakri14
14.09.2020 07:23

using namespace

Объяснение:

using namespace std;

int main()

{

 int a,sum=2;

  for (a = 1;a <= 50;a++){

      if(a%10==2){

          sum = sum * a;

      }      

  }

  cout <<sum / 2;

}

0,0(0 оценок)
Ответ:
kindness5
kindness5
14.09.2020 07:23

using System;

using System.Linq;

class NewClass

{

   

   static void Main()

   {

       int[] array = Enumerable.Range(0, 51).ToArray();//диапазон - [0; 50]!

       foreach(var i in array)

           System.Console.Write($"{i} ");

       System.Console.WriteLine();

       System.Console.WriteLine(array.Where(var => var % 10 == 2).Aggregate((var1, var2) => var1 * var2));

   }

}

Объяснение:

Диапазон от 0 до 50 включительно. Если диапазон нужен такой, чтобы 50 не включалось, измените 51 в методе Range() на 50.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?