В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
bibok3
bibok3
13.01.2023 22:26 •  Информатика

ОЧЕНЬ РЕШИТЬ ХОТЯ БЫ ОДНУ ИЗ ЭТИХ ЗАДАЧ!

1. Составить программу, по которой на экране будет напечатано: «Числа равны (numbers are equal)», если все три заданных числа равны, в противном случае будет напечатано максимальное число.

2. Рассчитать надбавку к зарплате за стаж, если стаж от 2 до 5 лет, надбавка составляет S1, если стаж от 5 до 10 лет – S2 руб. Ввести с клавиатуры зарплату и стаж, вывести надбавку и сумму к выплате. (в ответе код c++ или pascal)

Ответ:
ТЕМА3232
ТЕМА3232
14.10.2020 08:12

1.Var x, y, z, i:integer;

Begin

Readln(x);

Readln(y);

Readln(z);

If x=y then begin

If y=z then Writeln('numbers are equal' )

else begin if y>z then Writeln(y) else Writeln(z)

End; end

else begin if x>y then i:=x else i:=y;

If i>z then Writeln(i) else Writeln(z) end

2.const s1 = 10000;

const s2 = 15000;

var sum,zp,st: integer;

begin

write('Введите стаж: ');

readln(st);

write('Введите зарплату: ');

readln(zp);

if (st>=2) and (st<=5) then sum:=zp+s1

else if (st>5) then sum:=zp+s2;

writeln('Зарплата: ',zp);

writeln('Стаж: ',st);

if (st>=2) and (st<=5) then writeln('Надбавка: ',s1)

else if (st>5) then writeln('Надбавка: ',s2);

writeln('Сумма к выплате: ',sum);

end.

Объяснение:

Решил даже 2 :)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?