В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
VidioVizard
VidioVizard
04.05.2021 09:15 •  Информатика

30 ! 7 класс написать программу на паскале или на алгоритмическом языке. является ли натуральное число простым. если оно не простое, то найти количество его делителей​

Ответ:
Krupenyapolina
Krupenyapolina
08.06.2020 08:24

Відповідь:

Треба перебрати всі числа менші нього по черзі і поділити на них, якщо при діленні получається ціле число то в лічильник, який спочатку рівний нулю додати одиницю, якщо не ціле то перейти до наступного числа. В кінці коли лічильник буде рівний 2 це просте число а ні то це складне і потрібно вивести на екран результат лічильника. Ось приклад на Python:

o=0

m=int(input("Скажи число і я скажу чи воно просте."))

for h in range(1,m+1):

   if(m%h==0):

       o=o+1

if(o==2):

   print("Це число просте")

elif(o==1):

   print("Одиниця є окремим числом(не простим і не складним).")

else:

   print("Це число складене")

print("До побачення, натисни Enter для завершення")

p=input()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?