В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Для решения задач вам понадобиться:
- связать ввод и вывод программы соответственно с файлом, с которого будете читать данные, и с файлом, в который будете выводить результат ( ifstream имя_файла_1; ofstream_имя_файла_2);
- открыть файл с данными и открыть файл, в который будете выводить результат (имя_файла_1.open ( "input.txt" ); имя_файла_2.open ( "output.txt" );)
- читать данные, пока не закончится файл (while ( !имя_файла.eof() ));
- вывести число с заданным количеством знаков после запятой (имя_файла << fixed << setprecision (количество_знаков) << результат);
- закрыть файлы (имя_файла.close())
Желательно с объяснением к каждой строке
С++
Найти минимальное и максимальное из чётных положительных чисел, записанных в файле input.txt . Количество чисел неизвестно. Если в файле нет чётных положительных чисел, нужно вывести число 0. Результат записать в файл output.txt .

Входные данные

Целые числа записаны в файле input.txt в столбик, по одному в строке. Ввод заканчивается тогда, когда заканчиваются данные в файле.

Выходные данные

Программа должна вывести в файл output.txt минимальное и максимальное из чётных положительных чисел, разделив их пробелом. Если в файле нет чётных положительных чисел, нужно вывести число 0.

Ответ:
арсен2000
арсен2000
14.10.2020 07:23

f=open('input.txt')

g=open('output.txt','w')

s=[int(i) for i in f.read().split()]

s=[i for i in s if (i>0 and i %2 == 0)]

if s != []:

   print(str(min(s))+' '+str(max(s)), file = g)

else:

   print('0', file = g)

f.close()

g.close()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?