В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ggg289
ggg289
08.02.2023 15:10 •  Информатика

PYTHON
Делители числа
Напишите программу, которая отображает все делители числа N.
Входные данные: вводится единственное натуральное число n.
Выходные данные: на одной строке вывести все делители данного числа. Используйте для вывода параметр
end = " " с командой print(). Пример: print(x, end = " ").
Пример 1
Ввод:
12
Вывод:
1 2 3 4 6 12
В пайтоне

Ответ:
bagov2001
bagov2001
14.10.2020 07:23

a = int(input("Введи число: "))

for i in range(1,a+1):

   if a%i == 0:

       print(i,end = " ")


PYTHONДелители числа Напишите программу, которая отображает все делители числа N. Входные данные: вв
PYTHONДелители числа Напишите программу, которая отображает все делители числа N. Входные данные: вв
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?