В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Напишите программу угадывания пароля с использованием цикла WHILE
(повторять ввод пароля пользователем, пока он не совпадёт с тем, который "зашифрован в программе")

Ответ:
аолесдвда
аолесдвда
14.10.2020 06:40

var

pin : integer;

readPin : integer;

 

begin

 pin := 1234; //здесь напишешь  свой пин

  writeln('Write Pin :');

 readln(readPin);

 while readPin <> pin do begin

   writeln('Error wrong pin!');

   readln(readPin);

 end;

end.

Объяснение:

Вот

0,0(0 оценок)
Ответ:
Панель11
Панель11
14.10.2020 06:40

import random

code = ["954321"]

mineC = []

final = ""

i = 0

while True:

   while i < 6:

       wordC = random.randint(0, 9)

       mineC.append(wordC)

       i += 1

   if mineC != code:

       print(mineC)

       mineC.clear()

   if mineC == code:

       for i in mineC:

           final += i

       break

Работает только с паролями с цифрами

иначе придется выстраивать буквы по індексу и вызывать их так

   

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?