В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
точно2
точно2
18.09.2020 21:06 •  Информатика

Составить программу ,которая последовательно циклически запрашивает 40 целых положительных чисел и назодит минимальное значение среди чётных чисел. минимальное значение вывести на экран

Ответ:
Alesja4788
Alesja4788
08.06.2020 03:42

program nnn;

uses crt;

var

i,m:integer;

a:array[1..40] of integer;

begin

for i:=1 to 40 do

begin

read(a[i]);

end;

m:=a[1];

for i:=1 to 40 do

begin

if a[i] mod 2 = 0 then if m>a[i] then m:=a[i];

end;

writeln(m);

end.

если без массива:

program nnn;

uses crt;

var

i,c,m:integer;

begin

for i:=1 to 40 do

begin

read(c);

if i=1 then m:=c;

if c mod 2 = 0 then if m>c then m:=c;

end;

writeln(m);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?