В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
главный8
главный8
30.09.2020 13:38 •  Информатика

с решением Решение на языке Паскаль

На обработку поступает натуральное число, не превышающее 109. Нужно написать программу, которая выводит на экран произведение цифр числа, которые делятся на 2 и на 4. Если в числе нет таких цифр, требуется на экран вывести «NO».

Ответ:
emiliskenderov
emiliskenderov
24.08.2020 11:57

var N,digit,maxDigit: longint;

begin

readln(N);

maxDigit := N mod 10;

while N > 0 do

begin

digit := N mod 10;

if digit mod 3 = 0 then

if digit > maxDigit then

maxDigit := digit;

N := N div 10;

end;

if maxDigit = 0 then

writeln('NO')

else

writeln(maxDigit)

end.

Объяснение:

вроде так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?