В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
анабель125
анабель125
26.07.2022 08:39 •  Информатика

нужна ваша решение на языке паскаль

На обработку поступает натуральное число, не превышающее 10^9. Нужно написать программу, которая выводит на экран сумму нечетных цифр числа, которые делятся на 3. Если в числе нет таких цифр, требуется на экран вывести «NO».

Ответ:
05Artur10
05Artur10
14.10.2020 05:52

program z1;

var a,s: longint;

begin

write ('Введите число: ');

readln(a);

s:=0;

repeat

if (a mod 10 mod 2 = 1) and (a mod 10 mod 3 = 0) then s:=s+a mod 10;

a:=a div 10

until a=0;

if s = 0 then write('NO')

else writeln(s)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?