В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Селена451
Селена451
22.09.2022 23:42 •  Информатика

Pascal. Написать программу, которая позволяет транспонировать матрицу. Размерность вводится с клавиатуры, значения случайные числа от -10 до 10.

Ответ:
dasha45671dfd
dasha45671dfd
14.10.2020 05:33

program mtr1;

const N=10;

type iint:1..10;

       matrix: array [iint,iint] of integer;

var a: matrix;

     i,j: iint;

     m:iint;

    v:integer;

begin

       readln (m);

      randomize;

      (* заполнение матрицы *)

      for i:=1 to m do

     for j:=1 to m do

    a[i,j] := random(21)-10;

    for i:=1 to m do

    for j:=i to m do

    begin

            if i=j then

               continue;

     v:= a[i,j];

      a[i,j] := a[j,i];

      a[j,i] := v;

     end;

     for i:=1 m do

     begin

     for j:=1 to m do

     write(a[i,j],'  ');

     writeln;

     end;

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?