В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
kudgalina83
kudgalina83
22.11.2021 10:27 •  Информатика

Составить программу которая r раз находит m! значение r,m заполняются генератор случайных чисел с аргументом 6

Ответ:
evseeva090601
evseeva090601
08.06.2020 00:22

Объяснение:

function factorial(n:integer):integer;

var

 i, p:integer;

begin

 p:=1;

 for i:=1 to n do

   p:=p*i;

 factorial:=p;

end;

var

 r, m:integer;

 k:integer;

begin

 randomize;

 r:=random(6);

 writeln('r = ', r);

 for k:=1 to r do begin

   m:=random(6);

   writeln(m, '! = ', factorial(m));

 end;

 readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?