В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
beresnevav55p0as1j
beresnevav55p0as1j
21.02.2021 10:29 •  Информатика

Написать программу для расчёта суммы чисел, введённых пользователем. При этом пользователь вводит произвольное количество чисел, а для выхода из программы вводит ноль.

Ответ:
нан08
нан08
04.08.2020 07:51

#include <iostream>

#include <cmath>

#include <algorithm>

#pragma GCC optimize("Ofast")

#define ll long long

#define ld long double

using namespace std;

signed main() {

   ll sum = 0;

   ll k;

   while(cin >> k){

       if(k == 0)

           break;

       else

           sum += k;

   }

   cout << sum;

}

0,0(0 оценок)
Ответ:
08987654321
08987654321
04.08.2020 07:51

И паскаль на всякий случай :D

Объяснение:

program Hello;

var input,sum : Integer;

begin

wrtieln('Введите числа');

while true do

begin

read(input);

if 0 = input then break else sum := sum + input;

end;

writeln('sum = ', sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?