В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ALINAGREEN13
ALINAGREEN13
30.12.2020 09:02 •  Информатика

Напишите программу, которая получает число, а затем вычисляет сумму его цифр. Входной сигнал: три цифры номер выход: первая строка представляет собой сумму цифр(в python)

Ответ:
marinamashkina2
marinamashkina2
18.08.2020 09:59

n=int(input("Число: "))

sum = 0

while n>0:

   sum += n%10

   n=int(n/10)

   

print(sum)

Объяснение:


Напишите программу, которая получает число, а затем вычисляет сумму его цифр. Входной сигнал: три ци
0,0(0 оценок)
Ответ:
Mashirachan
Mashirachan
18.08.2020 09:59

python не знаю, но подскажу.

Объяснение:

тебе нужно найти остаток от деления на 10, потом остаток прибавить к сумме. После, входное число нацело разделить на 10. Оставшейся число пропускаем через эти шаги до того момента, пока оно не будет равняться 0

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?