В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Алентина
Алентина
20.06.2021 07:58 •  Информатика

Решить по информатике! 25 составить программу,которая определяет сколько слагаемых должно быть в сумме последовательности 2+4+6+8+.. и эта сумма оказалась больше заданного числа n. n> =0паскаль,8 класс!

Ответ:
smchnc2004
smchnc2004
07.06.2020 19:16

var

 i, c, s, n:integer;

Begin

 write('Введите n: ');

 readln(n);

 s:= 0;

 c:= 0;

 write('Последовательность: ');

 while i < n do begin

   s:= s + i;

   c:= c + 1;

   i:= i + 2;

   write(i, ' ');

 end;

 writeln;

 writeln('Сумма последовательности: ', s);

 writeln('Количество слагаемых: ', c);

END.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?