В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
jjiki
jjiki
12.12.2021 09:29 •  Информатика

Написать программу, вычисляющую произведение отрицательных элементов массива.

Ответ:
tokio272
tokio272
13.10.2020 23:30

#include <bits/stdc++.h>

using namespace std;

int main(int argc, char** argv){

unsigned int n;

long int a;

long long int inf = 1;

cin>>n;

for(int i=0;i<n;i++) {

cin>>a;

if(a < 0)

inf*=a;

}

cout<<inf<<endl;

}

Объяснение:

Я конечно не мастер по структурам данных  и профи по написанию алгоритмов. Но вроде работать должно.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?