В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Напишите программу, которая будет подсчитывать количество отрицательных и положительных введённых чисел с клавиатуры, подсчёт вести до тех пор пока не будет введён 0

Ответ:
kazachok2
kazachok2
07.06.2020 18:15

Var a, k, n:integer;

Begin

Write ('Вводите числа') ;

K:=0;n:=0;

Read(a) ;

While a<>0 do begin

If a>0 then k:=k+1;

If a<0 then n:=n+1;

Read(a) ;

End;

Writeln('Положительных ', k) ;

Writeln('Отрицательных ', n) ;

End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?