В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Dooolche
Dooolche
24.09.2022 17:25 •  Информатика

Написать программу вычисления модуля произведения отрицательных чисел, если индекс ячейки нечётное число.

Ответ:
volkovaolga75
volkovaolga75
13.10.2020 23:28

Program Primer;

var A: Array[1..20] Of Integer;

     i, n, s, p: Integer;

begin

    write ('n=');  

    readln (n);

    for i:=1 to n do readln (A[i]);   {ввод массива}                 s:= 0;  p:=1;

    for i:=1 to n do   {обработка массива}

    if (A[i] mod 2 <>0) and (A[i] mod 3 = 0) then

     begin

         s:=s+A[i];  

         p:= p*A[i];

     end;

    writeln ('s=', s, 'p=', p);

    readln;

    end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?