В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Cancanich
Cancanich
20.02.2022 12:05 •  Информатика

СОСТАВЬТЕ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ Составить программу. Коммерсант, имея стартовый капитал k рублей, занялся торговлей, которая ежемесячно увеличивает капитал на p%. Через сколько лет он накопит сумму s, достаточную для покупки собственного магазина?

Ответ:
Pikasso07
Pikasso07
04.09.2020 14:55

var

 n,s,p:integer;

 l,k:real;

 

begin

 readln(k);

 readln(p);

 readln(s);

 n:=0;

 repeat

  l:=k*p/100;

  k:=l+k;

  n:=n+1;

 until k > s;

 write(n div 12,'Лет',n mod 12,'Месяцов');

 readln;

end.

взял отсюда: https://studassistent.ru/turbo-pascal/kommersant-imeya-startovyy-kapital-turbo-pascal

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?