В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык

Обращаюсь к информатикам!
Составить программу в Паскале для обработки одномерного массива из 15 чисел. Значения элементов массива задать с клавиатуры самостоятельно. Найти наименьший элемент массива и его номер.
Заранее огромное

Ответ:
swietajakubiak
swietajakubiak
12.10.2020 22:24

Pascal ABC

Код:

var

  a: array [1..15] of integer;

  i, min: integer;

begin

    //заполнение массива

    for i := 1 to 15 do

        readln(a[i]);

    //поиск минимума

    min := 1;

    for i := 1 to 15 do

        if a[min] > a[i] then min := i;

    //вывод минимального и его номера

    writeln('Минимум: ', a[min], ' Номер: ', min);

end.

Тесты:

Ввод:

4 5 7 8 9 2 1 3 4 5 8 7 6 8 2

Вывод:

Минимум: 1 Номер: 7

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?