В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
jora2003123
jora2003123
11.04.2023 22:45 •  Информатика

Составить программу: если число четное, то возвести его в квадрат, иначе умножить его на 7 тремя блок-схема
2. алгоритмический язык
3. Pascal.

Ответ:
Kit1508
Kit1508
13.10.2020 14:16

1) блок-схема прикреплена

2) Алг. язык: (Тут я без понятия, правильно или нет)

нач цел x

ввод x

если x/2=0

то вывод x^2

иначе вывод x*7

кон

3) Pascal:

var x:integer;

begin

 writeln('Введите число');

 readln(x);

 if (x mod 2) = 0 then writeln('Число четное, его квадрат: ' + x**2)

 else writeln('Число НЕ четное: ' + x*7);

end.


Составить программу: если число четное, то возвести его в квадрат, иначе умножить его на 7 тремя бло
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?