В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
alina2834
alina2834
05.10.2021 13:12 •  Информатика

Необходимо было написать программу, которая позволяет найти наименьшее
число, большее 500, кратное 17 и вывести его на экран.
Программист торопился и написал программу с ошибками. Укажите строки,
в которых допущены ошибки.
Var x: integer;
Begin
x:= 500;
Repeat o
x := х – 1;
Until x mod 17 <> 0
Writeln (х);
End.​

Ответ:
malinovskaya10102006
malinovskaya10102006
13.10.2020 22:11

Var x: integer;

Begin

x:= 500;

Repeat o  //здесь непонятный символ o (должно быть: Repeat)

x := х – 1;   //здесь должно быть наоборот: к x надо прибавлять 1, так как надо найти число большее 500 (должно быть: x:= x + 1;)

Until x mod 17 <> 0   //здесь ошибка в том, что цикл repeat остановится когда число, деленное на 17, будет иметь остаток, а надо остановить тогда, когда при делении числа на 17 будет 0, то есть делится на 17 без остатка(должно быть: Until x mod 17 = 0;)

Writeln (х);

End.​

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?